CVE-2015-5287: ABRT abrt-hook-ccpp symlink attack on predictable core file (local root)

Exploited in the wild High 7.8 EPSS 5.0%

The abrt-hook-ccpp helper in the Automatic Bug Reporting Tool (ABRT) before 2.7.1 saved core dumps of programs whose name starts with 'abrt' to a predictable path such as /var/spool/abrt/abrt-hax-coredump or /var/tmp/abrt/abrt-hax-coredump and followed symlinks there, letting local users write files as root and escalate privileges. Red Hat fixed RHEL 7 in RHSA-2015:2505 (RHEL 6 is not affected). CISA added it to the Known Exploited Vulnerabilities catalog on 2026-08-26.

What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms

What to do now

  1. Check whether you run the affected software and which version (commands below).
  2. Install the fixed version for your system: see “Patch it” below.
  3. Restart the ABRT daemon and core-dump hook services (or reboot) after updating.
  4. Because this flaw is being exploited, also check the server for signs of compromise.

Affected and fixed versions

Affected:

Fixed in:

Am I affected?

rpm -q abrt abrt-addon-ccpp libreport

Patch it

Use the commands for your system. Distribution packages often keep an older version number with the fix backported, so compare with the fixed package versions in the table below, not only with the upstream version.

RHEL, AlmaLinux, Rocky, Oracle
sudo yum update abrt libreport

General update steps for every system are on the Linux and Unix & BSD pages; after updating, see which services to restart.

Fix status in Linux distributions

ReleasePackageStatusFixed version / advisory
Red Hat Enterprise Linux 7abrt-0:2.1.11-35.el7fixedRHSA-2015:2505
Red Hat Enterprise Linux 7libreport-0:2.1.11-31.el7fixedRHSA-2015:2505
RHEL 7abrtfixed2.1.11-35.el7 (RHSA-2015:2505)
RHEL 7libreportfixed2.1.11-31.el7 (RHSA-2015:2505)
RHEL 6abrtfixednot affected

From the Debian security tracker, Ubuntu CVE tracker and Red Hat Security Data API, refreshed every few hours.

CISA required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

This vulnerability affects an open-source component, third-party library, protocol, or proprietary implementation that could be used by different products. For more information, please see: https://github.com/abrt/abrt/commit/3c1b60cfa62d39e5fff5a53a5bc53dae189e740e ; BOD 26-04: https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk ; Forensics Triage Requirements: https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk ; https://nvd.nist.gov/vuln/detail/CVE-2015-5287

Sources

Page generated automatically from official sources on 2026-11-03 18:05 UTC and reviewed by an editor. Always confirm with your vendor's advisory.