CVE-2022-0995: Linux kernel watch_queue out-of-bounds write
Exploited in the wild High 7.8 EPSS 8.9% Linux kernel
The watch_queue event notification subsystem, added in Linux 5.8, has an out-of-bounds memory write in its filter handling. A local user can use it to overwrite kernel memory and gain root or crash the system; public exploits are referenced in the CVE record. It was fixed in Linux 5.17 and the 5.10.106, 5.15.29 and 5.16.15 stable releases, and RHEL kernels were never affected. CISA added it to KEV on 26 August 2026.
- CVE-2022-0995CVE identifier
- 7.8CVSS 3.1 base score (high)
- 2026-08-26added to CISA's exploited list (US federal deadline 2026-08-29)
- 8.9%EPSS: chance of exploitation in the next 30 days (higher than 95% of CVEs)
- 2022-03-25published
What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms
What to do now
- Check whether you run Linux kernel and which version (commands below).
- Install the fixed version for your system: see “Patch it” below.
- Reboot into the updated kernel. Ubuntu Livepatch covers it (LSN-0111-1, April 2025, and LSN-0112-1). SUSE shipped live patches for SLE 15 SP4 and SP5 (2025). RHEL is not affected.
- Because this flaw is being exploited, also check the server for signs of compromise.
Affected and fixed versions
Affected:
- Linux 5.8 through 5.10.105
- Linux 5.11 through 5.15.28
- Linux 5.16 through 5.16.14
Fixed in:
- Linux 5.10.106
- Linux 5.15.29
- Linux 5.16.15
- Linux 5.17
Am I affected?
uname -r
dpkg -l 'linux-image*' | grep ^ii # Debian/Ubuntu
rpm -q kernel # RHEL/Fedora/Amazon/SUSE (SUSE: rpm -q kernel-default)
Patch it
Use the commands for your system. Distribution packages often keep an older version number with the fix backported, so compare with the fixed package versions in the table below, not only with the upstream version.
Debian
sudo apt update
sudo apt upgrade
sudo reboot
# Debian 10 and older are not affected; Debian 12 and 13 ship fixed kernels.Ubuntu
sudo apt update
sudo apt upgrade
sudo reboot
# Ubuntu 24.04 and later are not affected.RHEL, AlmaLinux, Rocky, Oracle
# Red Hat: no shipped RHEL kernel was affected (RHEL 6-9 listed as not affected). Nothing to do.Fedora
sudo dnf upgrade --refresh kernel
sudo rebootSUSE / openSUSE
sudo zypper refresh
sudo zypper patch --category security
sudo rebootAmazon Linux
# Amazon Linux 2023
sudo dnf upgrade --releasever=latest 'kernel*'
# Amazon Linux 2
sudo yum update kernel
sudo rebootArch Linux
sudo pacman -Syu
sudo rebootAlpine
# as root
apk update
apk upgrade
rebootFreeBSD
not LinuxGeneral update steps for every system are on the Linux and Unix & BSD pages; after updating, see which services to restart.
Fix status in Linux distributions
| Release | Package | Status | Fixed version / advisory |
|---|---|---|---|
| Debian 12 | linux | fixed | 5.16.18-1 |
| Debian 13 | linux | fixed | 5.16.18-1 |
| Debian testing | linux | fixed | 5.16.18-1 |
| Ubuntu 18.04 (ESM) | linux | not fixed yet | |
| Ubuntu 20.04 (ESM) | linux | not fixed yet | |
| Ubuntu 26.10 | linux | not affected | |
| Ubuntu 22.04 | linux | fixed | 5.15.0-138.148 |
| Ubuntu 24.04 | linux | not affected | |
| Ubuntu 25.10 | linux | not affected | |
| Ubuntu 26.04 | linux | not affected | |
| Ubuntu 18.04 (ESM) | linux-hwe | not planned | |
| Ubuntu 18.04 (ESM) | linux-hwe-5.4 | not fixed yet | |
| Ubuntu 20.04 (ESM) | linux-hwe-5.8 | not planned | |
| Ubuntu 20.04 (ESM) | linux-hwe-5.11 | not planned | |
| Ubuntu 20.04 (ESM) | linux-hwe-5.13 | not planned | |
| Ubuntu 18.04 (ESM) | linux-hwe-edge | not affected | |
| Ubuntu 18.04 (ESM) | linux-kvm | not fixed yet | |
| Ubuntu 20.04 (ESM) | linux-kvm | not fixed yet | |
| Ubuntu 22.04 | linux-kvm | fixed | 5.15.0-1078.83 |
| Ubuntu 18.04 (ESM) | linux-aws | not fixed yet | |
| Ubuntu 20.04 (ESM) | linux-aws | not fixed yet | |
| Ubuntu 26.10 | linux-aws | not affected | |
| Ubuntu 22.04 | linux-aws | fixed | 5.15.0-1082.89 |
| Ubuntu 24.04 | linux-aws | not affected | |
| Ubuntu 25.10 | linux-aws | not affected | |
| Ubuntu 26.04 | linux-aws | not affected | |
| Ubuntu 18.04 (ESM) | linux-aws-5.0 | not planned | |
| Ubuntu 18.04 (ESM) | linux-aws-5.3 | not planned | |
| Ubuntu 18.04 (ESM) | linux-aws-5.4 | not fixed yet | |
| Ubuntu 20.04 (ESM) | linux-aws-5.8 | not planned | |
| Ubuntu 20.04 (ESM) | linux-aws-5.11 | not planned | |
| Ubuntu 20.04 (ESM) | linux-aws-5.13 | not planned | |
| Ubuntu 20.04 (ESM) | linux-azure | not fixed yet | |
| Ubuntu 26.10 | linux-azure | not affected | |
| Ubuntu 24.04 | linux-azure | not affected | |
| Ubuntu 22.04 | linux-azure | fixed | 5.15.0-1087.96 |
| Ubuntu 25.10 | linux-azure | not affected | |
| Ubuntu 26.04 | linux-azure | not affected | |
| Ubuntu 18.04 (ESM) | linux-azure | not planned | |
| Ubuntu 18.04 (ESM) | linux-azure-4.15 | not fixed yet | |
| Ubuntu 18.04 (ESM) | linux-azure-5.3 | not planned | |
| Ubuntu 18.04 (ESM) | linux-azure-5.4 | not fixed yet | |
| Ubuntu 20.04 (ESM) | linux-azure-5.8 | not planned | |
| Ubuntu 20.04 (ESM) | linux-azure-5.11 | not planned | |
| Ubuntu 26.10 | linux-azure-fde | not affected | |
| Ubuntu 20.04 (ESM) | linux-azure-fde | not affected | |
| Ubuntu 22.04 | linux-azure-fde | fixed | 5.15.0-1087.96.1 |
| Ubuntu 24.04 | linux-azure-fde | not affected | |
| Ubuntu 26.04 | linux-azure-fde | not affected | |
| Ubuntu 25.10 | linux-azure-fde | not affected | |
| Ubuntu 20.04 (ESM) | linux-bluefield | not fixed yet | |
| Ubuntu 18.04 (ESM) | linux-dell300x | not affected | |
| Ubuntu 18.04 (ESM) | linux-azure-edge | not planned | |
| Ubuntu 18.04 (ESM) | linux-fips | not fixed yet | |
| Ubuntu 20.04 (ESM) | linux-fips | not fixed yet | |
| Ubuntu 24.04 | linux-fips | not affected | |
| Ubuntu 22.04 | linux-fips | fixed | 5.15.0-138.148+fips1 |
| Ubuntu 20.04 (ESM) | linux-gcp | not fixed yet | |
| Ubuntu 26.10 | linux-gcp | not affected | |
| Ubuntu 24.04 | linux-gcp | not affected | |
From the Debian security tracker, Ubuntu CVE tracker and Red Hat Security Data API, refreshed every few hours.
CISA required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
This vulnerability affects an open-source component, third-party library, protocol, or proprietary implementation that could be used by different products. For more information, please see: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=93ce93587d36493f2f86921fa79921b3cba63fbb ; BOD 26-04: https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk ; Forensics Triage Requirements: https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk ; https://nvd.nist.gov/vuln/det
Sources
- CVE record CVE-2022-0995
- NVD CVE-2022-0995
- CISA KEV entry CVE-2022-0995
- Debian security tracker CVE-2022-0995
- Ubuntu CVE page CVE-2022-0995
- Red Hat CVE page CVE-2022-0995
- SUSE CVE page CVE-2022-0995
- Amazon Linux ALAS CVE page CVE-2022-0995
- Upstream fix (merge of watch_queue fixes)
- Linux 5.10.106 ChangeLog (watch_queue fixes)
- Linux 5.16.15 ChangeLog (watch_queue fixes)
- Red Hat Bugzilla 2063786
- Ubuntu Livepatch notice LSN-0111-1
- https://security.netapp.com/advisory/ntap-20220429-0001/
- CISA Known Exploited Vulnerabilities catalog
Page generated automatically from official sources on 2026-11-03 18:05 UTC and reviewed by an editor. Always confirm with your vendor's advisory.