CVE-2023-22894: Strapi private-field filtering leaks password hashes and reset tokens

Exploited in the wild Medium 4.9 EPSS 4.1%

Strapi 3.2.1 up to (not including) 4.8.0 lets API query filters reference private user columns, so an attacker can infer emails, password hashes and password reset tokens from API responses; Strapi also disclosed a method to exploit it without authentication to hijack admin accounts. Strapi 3.x is end of life and gets no fix; upgrade to 4.8.0 or later. CISA added it to the Known Exploited Vulnerabilities catalog on 2026-10-08.

What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms

What to do now

  1. Check whether you run the affected software and which version (commands below).
  2. Install the fixed version for your system: see “Patch it” below.
  3. Restart the affected service (or reboot for kernel and library updates) so the fix is actually in use.
  4. Because this flaw is being exploited, also check the server for signs of compromise.

Affected and fixed versions

Affected:

Fixed in:

Am I affected?

npm ls @strapi/strapi

Look for signs of exploitation

CISA required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

This vulnerability could affect an open-source component, third-party library, protocol, or proprietary implementation that could be used by different products. For more information, please see: https://strapi.io/blog/security-disclosure-of-vulnerabilities-cve ; https://github.com/strapi/strapi/releases ; BOD 26-04: https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk ; Forensics Triage Requirements: https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk ; https://nvd.nist.gov/vuln/detail/

Related vulnerabilities

Sources

Page generated automatically from official sources on 2026-11-03 18:05 UTC and reviewed by an editor. Always confirm with your vendor's advisory.