CVE-2025-3248: Langflow unauthenticated code injection in /api/v1/validate/code
Exploited in the wild Critical 9.8 EPSS 100.0%
Langflow before 1.3.0 executes code sent to the /api/v1/validate/code endpoint without requiring authentication, so anyone who can reach the server can run arbitrary Python on it. Self-hosted Langflow instances exposed to the internet are directly at risk. Fixed in Langflow 1.3.0; CISA added it to KEV on 5 May 2025 and lists it as used in ransomware campaigns.
- CVE-2025-3248CVE identifier
- 9.8CVSS 3.1 base score (critical)
- 2025-05-05added to CISA's exploited list (US federal deadline 2025-05-26)
- 100.0%EPSS: chance of exploitation in the next 30 days (higher than 100% of CVEs)
- 2025-04-07published
What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms
What to do now
- Check whether you run the affected software and which version (commands below).
- Install the fixed version for your system: see “Patch it” below.
- Restart the Langflow process or recreate its container.
- Because this flaw is being exploited, also check the server for signs of compromise.
Affected and fixed versions
Affected:
- Langflow before 1.3.0
- langflow-base before 0.3.0
Fixed in:
- Langflow 1.3.0
Am I affected?
pip show langflow | grep -i ^version
docker ps --format '{{.Image}}' | grep langflow
Patch it
Use the commands for your system. Distribution packages often keep an older version number with the fix backported, so compare with the fixed package versions in the table below, not only with the upstream version.
Docker images
docker pull langflowai/langflow:latest
# recreate the container from the new imageBuilt from source
pip install --upgrade 'langflow>=1.3.0'
# restart the langflow serviceGeneral update steps for every system are on the Linux and Unix & BSD pages; after updating, see which services to restart.
CISA required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
This vulnerability affects a common open-source project, third-party library, or a protocol used by different products. For more information, please see: https://github.com/advisories/GHSA-c995-4fw3-j39m ; https://nvd.nist.gov/vuln/detail/CVE-2025-3248
Related vulnerabilities
Sources
- CVE record CVE-2025-3248
- NVD CVE-2025-3248
- CISA KEV entry CVE-2025-3248
- GitHub advisory GHSA-rvqx-wpfh-mfx7 (Langflow Unauth RCE)
- Langflow 1.3.0 release
- Horizon3.ai: unauthenticated RCE in Langflow
- Langflow docs: Docker deployment
- https://github.com/langflow-ai/langflow/pull/6911
- https://www.vulncheck.com/advisories/langflow-unauthenticated-rce
- CISA Known Exploited Vulnerabilities catalog
Page generated automatically from official sources on 2026-11-03 18:05 UTC and reviewed by an editor. Always confirm with your vendor's advisory.