CVE-2025-58360: GeoServer unauthenticated XXE via WMS GetMap
Exploited in the wild Critical 9.8 EPSS 61.2%
GeoServer accepts XML input on the /geoserver/wms GetMap operation without restricting external entities, so an unauthenticated attacker can read arbitrary files from the server, make server-side requests to internal systems (SSRF) or cause denial of service. Fixed in GeoServer 2.25.6 and 2.26.2; the advisory recommends 2.25.6, 2.26.3 or 2.27.0. CISA added it to KEV on 11 December 2025.
- CVE-2025-58360CVE identifier
- 9.8CVSS 3.1 base score (critical)
- 2025-12-11added to CISA's exploited list (US federal deadline 2026-01-01)
- 61.2%EPSS: chance of exploitation in the next 30 days (higher than 99% of CVEs)
- 2025-11-25published
What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms
What to do now
- Check whether you run the affected software and which version (commands below).
- Install the fixed version for your system: see “Patch it” below.
- Restart GeoServer (Jetty/Tomcat or its container).
- Because this flaw is being exploited, also check the server for signs of compromise.
Affected and fixed versions
Affected:
- GeoServer before 2.25.6
- GeoServer 2.26.0 through 2.26.1
Fixed in:
- GeoServer 2.25.6
- GeoServer 2.26.2
- GeoServer 2.26.3
- GeoServer 2.27.0
Patch it
Use the commands for your system. Distribution packages often keep an older version number with the fix backported, so compare with the fixed package versions in the table below, not only with the upstream version.
Built from source
# install GeoServer 2.25.6, 2.26.3, 2.27.0 or later from https://geoserver.org/download/
# (keep your data directory) and restart the servlet containerGeneral update steps for every system are on the Linux and Unix & BSD pages; after updating, see which services to restart.
CISA required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
This vulnerability affects an open-source component, third-party library, or a protocol used by different products. For more information, please see: https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525 ; https://osgeo-org.atlassian.net/browse/GEOS-11922 ; https://nvd.nist.gov/vuln/detail/CVE-2025-58360
Sources
- CVE record CVE-2025-58360
- NVD CVE-2025-58360
- CISA KEV entry CVE-2025-58360
- GitHub advisory GHSA-fjf5-xgmq-5525
- GeoServer issue GEOS-11682
- CISA Known Exploited Vulnerabilities catalog
Page generated automatically from official sources on 2026-11-03 18:05 UTC and reviewed by an editor. Always confirm with your vendor's advisory.