CVE-2026-42208: LiteLLM proxy SQL injection in API key verification
Exploited in the wild Critical 9.3 EPSS 89.4%
During API key checks the LiteLLM proxy mixed the caller-supplied key into the SQL query text, so an unauthenticated attacker can send a crafted Authorization header to any LLM route (such as POST /chat/completions) and reach the query via the error-handling path. That lets them read and possibly modify the proxy database, leading to unauthorised access to the proxy and the credentials it manages. Fixed in 1.83.7; CISA added it to KEV on 8 May 2026.
- CVE-2026-42208CVE identifier
- 9.3CVSS 4.0 base score (critical)
- 2026-05-08added to CISA's exploited list (US federal deadline 2026-05-11)
- 89.4%EPSS: chance of exploitation in the next 30 days (higher than 100% of CVEs)
- 2026-05-08published
What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms
What to do now
- Check whether you run the affected software and which version (commands below).
- Install the fixed version for your system: see “Patch it” below.
- Restart the LiteLLM proxy; rotate keys stored in it if it was exposed while vulnerable.
- If you cannot patch today, apply the temporary mitigation below and patch as soon as possible.
- Because this flaw is being exploited, also check the server for signs of compromise.
Affected and fixed versions
Affected:
- LiteLLM 1.81.16 before 1.83.7
Fixed in:
- LiteLLM 1.83.7
Am I affected?
pip show litellm | grep -i ^version
docker ps --format '{{.Image}}' | grep -i litellm
Patch it
Use the commands for your system. Distribution packages often keep an older version number with the fix backported, so compare with the fixed package versions in the table below, not only with the upstream version.
Docker images
# move to the v1.83.7-stable image tag or later and recreate the containerBuilt from source
pip install --upgrade 'litellm[proxy]>=1.83.7'
# restart the proxyGeneral update steps for every system are on the Linux and Unix & BSD pages; after updating, see which services to restart.
If you cannot patch yet
- If you cannot upgrade, set disable_error_logs: true under general_settings in the proxy config; this removes the path by which unauthenticated input reaches the vulnerable query (LiteLLM).
CISA required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
https://github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc ; https://nvd.nist.gov/vuln/detail/CVE-2026-42208
Related vulnerabilities
Sources
- CVE record CVE-2026-42208
- NVD CVE-2026-42208
- CISA KEV entry CVE-2026-42208
- Red Hat CVE page CVE-2026-42208
- GitHub advisory GHSA-r75f-5x8p-qvmc
- LiteLLM v1.83.7-stable release
- CISA Known Exploited Vulnerabilities catalog
Page generated automatically from official sources on 2026-11-03 18:05 UTC and reviewed by an editor. Always confirm with your vendor's advisory.