CVE-2026-53362: Linux kernel IPv6 UDP fragment out-of-bounds write (ipv6_frag_escape)

Exploited in the wild High 7.8 EPSS 0.7% Linux kernel

__ip6_append_data() in the IPv6 output path undersizes the buffer when a corked UDPv6 datagram crosses a fragment boundary while MSG_SPLICE_PAGES is used (for example splice() from a pipe into a UDP socket), giving a controlled 15-byte out-of-bounds write into skb_shared_info. A local unprivileged user can turn this into root, and Red Hat says it can be used to escape a container and bypass SELinux. Linux 6.0 and later are affected (RHEL 8 and 9 are not); CISA added it to KEV on 27 August 2026.

Also known as “ipv6_frag_escape”.

What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms

What to do now

  1. Check whether you run Linux kernel and which version (commands below).
  2. Install the fixed version for your system: see “Patch it” below.
  3. Reboot into the updated kernel. Live patches: RHEL 10.2 kpatch-patch (RHSA-2026:43826); SUSE kernel-livepatch for SLES 15 SP6, 15 SP7 and 16.0; Amazon Linux 2023 kernel-livepatch updates. No Ubuntu Livepatch notice covers this CVE.
  4. If you cannot patch today, apply the temporary mitigation below and patch as soon as possible.
  5. Because this flaw is being exploited, also check the server for signs of compromise.

Affected and fixed versions

Affected:

Fixed in:

Am I affected?

uname -r
dpkg -l 'linux-image*' | grep ^ii   # Debian/Ubuntu
rpm -q kernel   # RHEL/Fedora/Amazon/SUSE (SUSE: rpm -q kernel-default)
sysctl user.max_user_namespaces

Patch it

Use the commands for your system. Distribution packages often keep an older version number with the fix backported, so compare with the fixed package versions in the table below, not only with the upstream version.

Debian
sudo apt update
sudo apt upgrade
sudo reboot
# Debian 11 'linux' (5.10) is not affected; only the linux-6.1 backport needs updating there.
Ubuntu
sudo apt update
sudo apt upgrade
sudo reboot
# Ubuntu 22.04 GA and older are not affected. As of 3 Nov 2026 Ubuntu lists 22.04 HWE 6.8 as 'pending' and 24.04 HWE 6.17 as 'needed'.
RHEL, AlmaLinux, Rocky, Oracle
# Only RHEL 10 is affected (RHEL 8 and 9 are not, per Red Hat).
sudo dnf upgrade kernel
sudo reboot
# RHEL 10.2 kpatch: sudo dnf install "kpatch-patch = $(uname -r)"
Fedora
sudo dnf upgrade --refresh kernel
sudo reboot
SUSE / openSUSE
sudo zypper refresh
sudo zypper patch --category security
sudo reboot
Amazon Linux
# Amazon Linux 2023
sudo dnf upgrade --releasever=latest 'kernel*'
sudo reboot
# Amazon Linux 2 kernels are not affected.
Arch Linux
sudo pacman -Syu
sudo reboot
Alpine
# as root
apk update
apk upgrade
reboot
FreeBSD
not Linux

General update steps for every system are on the Linux and Unix & BSD pages; after updating, see which services to restart.

Fix status in Linux distributions

ReleasePackageStatusFixed version / advisory
Debian 12linuxfixed6.1.177-1
Debian 13linuxfixed6.12.95-1
Debian testinglinuxfixed7.1.3-1
Ubuntu 18.04 (ESM)linuxnot affected
Ubuntu 20.04 (ESM)linuxnot affected
Ubuntu 22.04linuxnot affected
Ubuntu 24.04linuxfixed6.8.0-147.147
Ubuntu 25.10linuxnot planned
Ubuntu 26.04linuxfixed7.0.0-31.31
Ubuntu 26.10linuxnot affected
Ubuntu 18.04 (ESM)linux-hwenot planned
Ubuntu 18.04 (ESM)linux-hwe-5.4not affected
Ubuntu 20.04 (ESM)linux-hwe-5.8not planned
Ubuntu 20.04 (ESM)linux-hwe-5.11not planned
Ubuntu 20.04 (ESM)linux-hwe-5.13not planned
Ubuntu 20.04 (ESM)linux-hwe-5.15not affected
Ubuntu 22.04linux-hwe-5.19not planned
Ubuntu 22.04linux-hwe-6.2not planned
Ubuntu 22.04linux-hwe-6.5not planned
Ubuntu 22.04linux-hwe-6.8fix pending
Ubuntu 24.04linux-hwe-6.11not planned
Ubuntu 24.04linux-hwe-6.14not planned
Ubuntu 24.04linux-hwe-6.17not fixed yet
Ubuntu 24.04linux-hwe-7.0fixed7.0.0-31.31~24.04.1
Ubuntu 18.04 (ESM)linux-hwe-edgenot planned
Ubuntu 18.04 (ESM)linux-kvmnot affected
Ubuntu 20.04 (ESM)linux-kvmnot affected
Ubuntu 22.04linux-kvmnot affected
Ubuntu 22.04linux-allwinner-5.19not planned
Ubuntu 18.04 (ESM)linux-awsnot affected
Ubuntu 20.04 (ESM)linux-awsnot affected
Ubuntu 22.04linux-awsnot affected
Ubuntu 24.04linux-awsfixed6.8.0-1067.70
Ubuntu 26.04linux-awsfixed7.0.0-1012.12
Ubuntu 25.10linux-awsnot planned
Ubuntu 26.10linux-awsnot affected
Ubuntu 18.04 (ESM)linux-aws-5.0not planned
Ubuntu 18.04 (ESM)linux-aws-5.3not planned
Ubuntu 18.04 (ESM)linux-aws-5.4not affected
Ubuntu 20.04 (ESM)linux-aws-5.8not planned
Ubuntu 20.04 (ESM)linux-aws-5.11not planned
Ubuntu 20.04 (ESM)linux-aws-5.13not planned
Ubuntu 20.04 (ESM)linux-aws-5.15not affected
Ubuntu 22.04linux-aws-5.19not planned
Ubuntu 22.04linux-aws-6.2not planned
Ubuntu 22.04linux-aws-6.5not planned
Ubuntu 22.04linux-aws-6.8fix pending
Ubuntu 24.04linux-aws-6.14not planned
Ubuntu 24.04linux-aws-6.17not planned
Ubuntu 18.04 (ESM)linux-azurenot planned
Ubuntu 20.04 (ESM)linux-azurenot affected
Ubuntu 22.04linux-azurenot affected
Ubuntu 26.04linux-azurefixed7.0.0-1014.14
Ubuntu 24.04linux-azurefixed6.8.0-1071.79
Ubuntu 25.10linux-azurenot planned
Ubuntu 26.10linux-azurenot affected
Ubuntu 18.04 (ESM)linux-azure-4.15not affected
Ubuntu 18.04 (ESM)linux-azure-5.3not planned
Ubuntu 18.04 (ESM)linux-azure-5.4not affected
Ubuntu 20.04 (ESM)linux-azure-5.8not planned

From the Debian security tracker, Ubuntu CVE tracker and Red Hat Security Data API, refreshed every few hours.

If you cannot patch yet

CISA required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

This vulnerability affects an open-source component, third-party library, protocol, or proprietary implementation that could be used by different products. For more information, please see: ; https://git.kernel.org/stable/c/14200d435af9a9eeb444f529fc2f689a236b7962; https://git.kernel.org/stable/c/65fb14cbebb0cd0eff903a22d33537ddc8b95769; https://git.kernel.org/stable/c/46f201f8b4c39633a1fa3dc12459f506d470993d; https://git.kernel.org/stable/c/6374fb9edf72c67a118a2c214a0dddd04c921e0a; https://git.kernel.org/stable/c/e9eacf19281ea2498b36291b56c9606118c2d74e; https://git.kernel.org/stable/c/736b38

Related vulnerabilities

Sources

Page generated automatically from official sources on 2026-11-03 18:05 UTC and reviewed by an editor. Always confirm with your vendor's advisory.