CVE-2026-9198: Langflow OSS auto_login + validate/code chain: unauthenticated RCE
Exploited in the wild Critical 9.8 EPSS 28.7%
Langflow OSS 1.0.0 through 1.10.0 lets any network caller get a SUPERUSER bearer token from /api/v1/auto_login and then submit Python to /api/v1/validate/code, which executes it via exec(), giving unauthenticated remote code execution on default deployments (CVSS 9.8). IBM fixed it in Langflow OSS 1.10.1 (bulletin of 2 July 2026) and lists no workarounds. CISA added it to the Known Exploited Vulnerabilities catalog on 2026-08-04.
- CVE-2026-9198CVE identifier
- 9.8CVSS 3.1 base score (critical)
- 2026-08-04added to CISA's exploited list (US federal deadline 2026-08-07)
- 28.7%EPSS: chance of exploitation in the next 30 days (higher than 98% of CVEs)
- 2026-07-17published
What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms
What to do now
- Check whether you run the affected software and which version (commands below).
- Install the fixed version for your system: see “Patch it” below.
- Restart the Langflow server/container.
- If you cannot patch today, apply the temporary mitigation below and patch as soon as possible.
- Because this flaw is being exploited, also check the server for signs of compromise.
Affected and fixed versions
Affected:
- Langflow OSS 1.0.0 through 1.10.0
Fixed in:
- Langflow OSS 1.10.1
Am I affected?
pip show langflow | grep -i ^version
Patch it
Use the commands for your system. Distribution packages often keep an older version number with the fix backported, so compare with the fixed package versions in the table below, not only with the upstream version.
Docker images
docker pull langflowai/langflow:1.10.1 # or later
# recreate the container from the new imageBuilt from source
pip install --upgrade 'langflow>=1.10.1'
# restart 'langflow run'General update steps for every system are on the Linux and Unix & BSD pages; after updating, see which services to restart.
If you cannot patch yet
- IBM lists no workarounds; upgrade to 1.10.1.
Look for signs of exploitation
- Web/proxy logs showing requests to /api/v1/auto_login from external addresses followed by POST /api/v1/validate/code.
CISA required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
https://www.ibm.com/support/pages/node/7278927 ; BOD 26-04: https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk ; Forensics Triage Requirements: https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk ; https://nvd.nist.gov/vuln/detail/CVE-2026-9198
Sources
- IBM Security Bulletin: Langflow OSS (CVE-2026-9198)
- PyPI langflow 1.10.1
- Docker Hub langflowai/langflow
- CVE record CVE-2026-9198
- CVE-2026-9198 on CVE.org
- CVE-2026-9198 on NVD
- CISA Known Exploited Vulnerabilities catalog
Page generated automatically from official sources on 2026-11-03 18:05 UTC and reviewed by an editor. Always confirm with your vendor's advisory.