CVE-2026-102489: Zammad 6.3-6.5 session hijack leading to RCE as the zammad user
Exploited in the wild Critical 9.4 EPSS 22.5% Linux kernel
Zammad 6.3.0 to 6.5.4 has a session hijack (session fixation) flaw that leads to remote code execution as the zammad user; the code is also present in 7.0.0 to 7.1.x but not exploitable because of the newer runtime environment. DIVD found it after attackers used it, chained with the CVE-2026-102490 local root flaw, to breach DIVD in September 2026. Zammad hardened the code in 7.2.0 and shipped an emergency 6.5.5 release for the unsupported 6.5 series; CISA added it to the Known Exploited Vulnerabilities catalog on 2026-10-02.
- CVE-2026-102489CVE identifier
- 9.4CVSS 4.0 base score (critical)
- 2026-10-02added to CISA's exploited list (US federal deadline 2026-10-05)
- 22.5%EPSS: chance of exploitation in the next 30 days (higher than 98% of CVEs)
- 2026-09-30published
What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms
What to do now
- Check whether you run Linux kernel and which version (commands below).
- Install the fixed version for your system: see “Patch it” below.
- The package update restarts Zammad. Zammad 6.5.5 is only available from the new package repository: migrate the repository first (see Zammad host-upgrade/repository-migration docs).
- If you cannot patch today, apply the temporary mitigation below and patch as soon as possible.
- Because this flaw is being exploited, also check the server for signs of compromise.
Affected and fixed versions
Affected:
- Zammad 6.3.0 through 6.5.4 (exploitable)
- Zammad 7.0.0 through 7.1.x (code present, not exploitable per Zammad and DIVD)
Fixed in:
- Zammad 6.5.5 (emergency fix, WebSocket server hardening)
- Zammad 7.2.0 (hardening); 7.2.2 recommended
Am I affected?
dpkg -l zammad | grep ^ii
rpm -q zammad
Patch it
Use the commands for your system. Distribution packages often keep an older version number with the fix backported, so compare with the fixed package versions in the table below, not only with the upstream version.
Debian
sudo systemctl stop zammad
# back up Zammad first
sudo apt update
sudo apt-mark hold zammad
sudo apt upgrade
sudo apt-mark unhold zammad
sudo apt upgradeUbuntu
sudo systemctl stop zammad
# back up Zammad first
sudo apt update
sudo apt-mark hold zammad
sudo apt upgrade
sudo apt-mark unhold zammad
sudo apt upgradeRHEL, AlmaLinux, Rocky, Oracle
sudo systemctl stop zammad
# back up Zammad first
sudo dnf upgrade --exclude zammad
sudo dnf upgradeFedora
sudo dnf upgrade --refresh kernelSUSE / openSUSE
sudo systemctl stop zammad
# back up Zammad first
sudo zypper refresh
sudo zypper addlock zammad
sudo zypper update
sudo zypper removelock zammad
sudo zypper updateAmazon Linux
sudo dnf upgrade --releasever=latest kernel kernel6.12Arch Linux
sudo pacman -SyuAlpine
apk update && apk upgrade linux-lts linux-virtFreeBSD
not LinuxGeneral update steps for every system are on the Linux and Unix & BSD pages; after updating, see which services to restart.
If you cannot patch yet
- Upgrade to Zammad 7.2.2, or to 6.5.5 as a temporary measure if you cannot leave 6.5 yet (Zammad).
- DIVD advises upgrading to Zammad 7 or taking vulnerable instances offline.
Look for signs of exploitation
- DIVD publishes a log check script to search Zammad log files for its indicators of compromise (linked from the DIVD-2026-00015 case page).
CISA required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
https://zammad.com/en/product/releases/ ; https://community.zammad.org/t/take-care-local-privilege-escalation-cve-2026-102490-is-reported-as-being-actively-exploited/21297/2 ; BOD 26-04: https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk ; Forensics Triage Requirements: https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk ; https://nvd.nist.gov/vuln/detail/CVE-2026-102489
Related vulnerabilities
Sources
- Zammad 6.5.5 release notes
- CVE record CVE-2026-102489
- Zammad Security Advisory: CVE-2026-102489 and CVE-2026-102490
- DIVD-2026-00015: Vulnerabilities in Zammad
- Zammad community: CVE-2026-102490 reported as actively exploited
- Zammad docs: Updating Zammad (package installation)
- Zammad docs: Host upgrade and repository migration
- https://csirt.divd.nl/DIVD-2026-00015
- https://csirt.divd.nl/CVE-2026-102489
- https://community.zammad.org/t/take-care-local-privilege-escalation-cve-2026-102490-is-reported-as-being-actively-exploited/21297/2
- CVE-2026-102489 on CVE.org
- CVE-2026-102489 on NVD
- CISA Known Exploited Vulnerabilities catalog
Page generated automatically from official sources on 2026-11-03 18:05 UTC and reviewed by an editor. Always confirm with your vendor's advisory.