CVE-2026-102490: Zammad DEB/RPM packages (packager.io) local privilege escalation to root
Exploited in the wild Critical 9.4 EPSS 10.9% Linux kernel
In Zammad installed from the packager.io DEB/RPM packages, service processes started as root and executed files owned and writable by the zammad account before dropping privileges, so anyone with code execution as the zammad user could become root within seconds (services auto-restart). All packaged releases from 1.5.0 through 7.2.1 are affected; source installs and the official container images are not. DIVD found it while investigating the breach of its own network, chained with CVE-2026-102489; Zammad 7.2.2 fixes it and CISA added it to the Known Exploited Vulnerabilities catalog on 2026-10-02.
- CVE-2026-102490CVE identifier
- 9.4CVSS 4.0 base score (critical)
- 2026-10-02added to CISA's exploited list (US federal deadline 2026-10-05)
- 10.9%EPSS: chance of exploitation in the next 30 days (higher than 96% of CVEs)
- 2026-09-30published
What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms
What to do now
- Check whether you run Linux kernel and which version (commands below).
- Install the fixed version for your system: see “Patch it” below.
- The package update restarts Zammad; follow any additional steps in the release notes.
- If you cannot patch today, apply the temporary mitigation below and patch as soon as possible.
- Because this flaw is being exploited, also check the server for signs of compromise.
Affected and fixed versions
Affected:
- Zammad DEB/RPM packages 1.5.0 through 7.2.1
Fixed in:
- Zammad 7.2.2
Am I affected?
dpkg -l zammad | grep ^ii
rpm -q zammad
Patch it
Use the commands for your system. Distribution packages often keep an older version number with the fix backported, so compare with the fixed package versions in the table below, not only with the upstream version.
Debian
sudo systemctl stop zammad
# back up Zammad first
sudo apt update
sudo apt-mark hold zammad
sudo apt upgrade
sudo apt-mark unhold zammad
sudo apt upgradeUbuntu
sudo systemctl stop zammad
# back up Zammad first
sudo apt update
sudo apt-mark hold zammad
sudo apt upgrade
sudo apt-mark unhold zammad
sudo apt upgradeRHEL, AlmaLinux, Rocky, Oracle
sudo systemctl stop zammad
# back up Zammad first
sudo dnf upgrade --exclude zammad
sudo dnf upgradeFedora
sudo dnf upgrade --refresh kernelSUSE / openSUSE
sudo systemctl stop zammad
# back up Zammad first
sudo zypper refresh
sudo zypper addlock zammad
sudo zypper update
sudo zypper removelock zammad
sudo zypper updateAmazon Linux
sudo dnf upgrade --releasever=latest kernel kernel6.12Arch Linux
sudo pacman -SyuAlpine
apk update && apk upgrade linux-lts linux-virtFreeBSD
not LinuxGeneral update steps for every system are on the Linux and Unix & BSD pages; after updating, see which services to restart.
If you cannot patch yet
- Restrict access to the underlying Zammad server to trusted administrators only (Zammad).
- Zammad 6.5 and older are out of support: upgrade to 7.2.2 (6.5.5 exists only as an emergency fix for CVE-2026-102489 and requires the new package repository).
CISA required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
https://zammad.com/en/product/releases/ ; https://community.zammad.org/t/take-care-local-privilege-escalation-cve-2026-102490-is-reported-as-being-actively-exploited/21297/2 ; BOD 26-04: https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk ; Forensics Triage Requirements: https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk ; https://nvd.nist.gov/vuln/detail/CVE-2026-102490
Related vulnerabilities
Sources
- Zammad advisory GHSA-p97w-927q-8vxq
- Zammad 7.2.2 release notes
- CVE record CVE-2026-102490
- Zammad Security Advisory: CVE-2026-102489 and CVE-2026-102490
- DIVD-2026-00015: Vulnerabilities in Zammad
- Zammad community: CVE-2026-102490 reported as actively exploited
- Zammad docs: Updating Zammad (package installation)
- Zammad docs: Host upgrade and repository migration
- https://csirt.divd.nl/DIVD-2026-00015
- https://csirt.divd.nl/CVE-2026-102490
- CVE-2026-102490 on CVE.org
- CVE-2026-102490 on NVD
- CISA Known Exploited Vulnerabilities catalog
Page generated automatically from official sources on 2026-11-03 18:05 UTC and reviewed by an editor. Always confirm with your vendor's advisory.