CVE-2026-110264: GitLab Org-mode regex integer overflow allows unauthenticated RCE

Critical 10.0 EPSS 1.3% GitLab CE/EE

GitLab CE/EE renders Org-mode files with the org-ruby gem, which builds a regular expression from an attacker-supplied #+TODO: keyword; a keyword with more than 32,767 repeats overflows a 16-bit counter in Ruby's Onigmo regex engine and causes an out-of-bounds write at match time. An unauthenticated attacker can turn this into code execution on the GitLab server as the git user, exposing gitlab-secrets.json, CI/CD variables, runner and access tokens, and every repository. GitLab rates it critical (CVSS 10.0); it affects every version since 7.0, and the fix is a patch to the Ruby that GitLab bundles (also in Ruby 4.0.9, 3.4.12, 3.3.13).

What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms

What to do now

  1. Check whether you run GitLab CE/EE and which version (commands below).
  2. Install the fixed version for your system: see “Patch it” below.
  3. GitLab says this patch includes database migrations (regular migrations in 19.4.3 and 19.3.6): single-node instances are down until migrations finish; multi-node instances can use the zero-downtime upgrade procedure. Run `sudo gitlab-rake gitlab:check` afterwards. If exploitation is suspected, rotate gitlab-secrets.json secrets, runner and access tokens and CI/CD variables.

Affected and fixed versions

Affected:

Fixed in:

Am I affected?

sudo gitlab-rake gitlab:env:info
dpkg -l gitlab-ee gitlab-ce 2>/dev/null | grep ^ii
rpm -q gitlab-ee gitlab-ce
/opt/gitlab/embedded/bin/ruby -v

Patch it

Use the commands for your system. Distribution packages often keep an older version number with the fix backported, so compare with the fixed package versions in the table below, not only with the upstream version.

Debian
sudo apt update && sudo apt install gitlab-ee=19.5.1-ee.0
# other series: 19.4.x -> 19.4.3, 19.3.x -> 19.3.6, 19.2.x -> 19.2.9, 19.1.x -> 19.1.9, 19.0.x -> 19.0.10, 18.11.x -> 18.11.13
# Community Edition: sudo apt update && sudo apt install gitlab-ce=19.5.1-ce.0
Ubuntu
sudo apt update && sudo apt install gitlab-ee=19.5.1-ee.0
# other series: 19.4.x -> 19.4.3, 19.3.x -> 19.3.6, 19.2.x -> 19.2.9, 19.1.x -> 19.1.9, 19.0.x -> 19.0.10, 18.11.x -> 18.11.13
# Community Edition: sudo apt update && sudo apt install gitlab-ce=19.5.1-ce.0
RHEL, AlmaLinux, Rocky, Oracle
# RHEL/AlmaLinux/Oracle Linux 9 (use .el8 on EL8)
sudo dnf install gitlab-ee-19.5.1-ee.0.el9
# other series: 19.4.3, 19.3.6, 19.2.9, 19.1.9, 19.0.10, 18.11.13
# Community Edition: sudo dnf install gitlab-ce-19.5.1-ce.0.el9
Fedora
not packaged
SUSE / openSUSE
not in distro repos: packages.gitlab.com gitlab-ce / gitlab-ee
Amazon Linux
not in distro repos: packages.gitlab.com gitlab-ee
Arch Linux
sudo pacman -Syu
Alpine
apk update && apk upgrade gitlab-runner (runner only)
FreeBSD
pkg update && pkg upgrade gitlab-ce
Docker images
# in docker-compose.yml set: image: gitlab/gitlab-ee:19.5.1-ee.0  (other series: 19.4.3, 19.3.6, 19.2.9, 19.1.9, 19.0.10, 18.11.13; CE: gitlab/gitlab-ce:<version>-ce.0)
docker compose pull
docker compose up -d
Built from source
Self-compiled installs and custom images with their own Ruby: upgrading GitLab is not enough; also upgrade Ruby to 3.3.13, 3.4.12, 4.0.9 or later (GitLab's fix is a patch to Ruby that only ships in the official packages and images).

General update steps for every system are on the Linux and Unix & BSD pages; after updating, see which services to restart.

Fix status in Linux distributions

ReleasePackageStatusFixed version / advisory
Debian 12ruby3.1not fixed yet
Debian 13ruby3.3not fixed yet
Debian testingruby3.3not fixed yet
Red Hat Enterprise Linux 9rubyaffected
Red Hat Enterprise Linux 9ruby:3.3/rubyaffected
Red Hat Enterprise Linux 9ruby:4.0/rubyaffected
Red Hat Enterprise Linux 8ruby:2.5/rubyaffected
Red Hat Enterprise Linux 8ruby:3.3/rubyaffected
Red Hat Enterprise Linux 7rubyaffected
Red Hat Enterprise Linux 6rubyaffected
Red Hat Enterprise Linux 10rubyaffected
Red Hat Enterprise Linux 10ruby4.0affected

From the Debian security tracker, Ubuntu CVE tracker and Red Hat Security Data API, refreshed every few hours.

Look for signs of exploitation

Related vulnerabilities

Sources

Page generated automatically from official sources on 2026-11-03 18:05 UTC and reviewed by an editor. Always confirm with your vendor's advisory.