CVE-2026-97229: GitLab CI/CD regular expression integer overflow allows unauthenticated RCE

Exploited in the wild Critical 10.0 EPSS 27.7% GitLab CE/EE

An integer overflow in the Onigmo regular-expression compiler in the Ruby that GitLab CE/EE ships lets an unauthenticated attacker run code on the GitLab server by submitting a specially crafted regular expression in a CI/CD configuration; it bypasses the incomplete fix for CVE-2026-93577 in GitLab 19.4.1. GitLab fixed it in 19.4.2, 19.3.5 and 19.2.8 on October 12, 2026, and the underlying Ruby bug is fixed in Ruby 4.0.8, 3.4.12 and 3.3.13, so other Ruby applications that compile attacker-controlled regular expressions may also be exposed. CISA added it to the Known Exploited Vulnerabilities catalog on 2026-10-29 as exploited in the wild.

What do these terms mean? CVE · CVSS score · exploited (KEV) · EPSS · backported fix · all terms

What to do now

  1. Check whether you run GitLab CE/EE and which version (commands below).
  2. Install the fixed version for your system: see “Patch it” below.
  3. GitLab says this patch includes database migrations: single-node instances are down until the migrations finish, while multi-node instances can use the zero-downtime upgrade procedure. Upgrade GitLab Runner to the matching version and run `sudo gitlab-rake gitlab:check` afterwards.
  4. Because this flaw is being exploited, also check the server for signs of compromise.

Affected and fixed versions

Affected:

Fixed in:

Am I affected?

sudo gitlab-rake gitlab:env:info
dpkg -l gitlab-ee gitlab-ce 2>/dev/null | grep ^ii
rpm -q gitlab-ee gitlab-ce

Patch it

Use the commands for your system. Distribution packages often keep an older version number with the fix backported, so compare with the fixed package versions in the table below, not only with the upstream version.

Debian
sudo apt update && sudo apt install gitlab-ee=19.4.2-ee.0
# other series: 19.3.x -> 19.3.5, 19.2.x -> 19.2.8
# Community Edition: sudo apt update && sudo apt install gitlab-ce=19.4.2-ce.0
Ubuntu
sudo apt update && sudo apt install gitlab-ee=19.4.2-ee.0
# other series: 19.3.x -> 19.3.5, 19.2.x -> 19.2.8
# Community Edition: sudo apt update && sudo apt install gitlab-ce=19.4.2-ce.0
RHEL, AlmaLinux, Rocky, Oracle
# RHEL/AlmaLinux/Oracle Linux 9 (use .el8 on EL8)
sudo dnf install gitlab-ee-19.4.2-ee.0.el9
# other series: 19.3.x -> 19.3.5, 19.2.x -> 19.2.8
# Community Edition: sudo dnf install gitlab-ce-19.4.2-ce.0.el9
Fedora
not packaged
SUSE / openSUSE
# openSUSE Leap 15.5
sudo zypper install gitlab-ee=19.4.2-ee.sles15
# SLES 12
sudo zypper install gitlab-ee=19.4.2-ee.0.sles12
# other series: 19.3.x -> 19.3.5, 19.2.x -> 19.2.8; Community Edition: gitlab-ce=<version>-ce.sles15 (SLES 12: -ce.0.sles12)
Amazon Linux
# Amazon Linux 2023
sudo dnf install gitlab-ee-19.4.2-ee.0.amazon2023
# Amazon Linux 2
sudo yum install gitlab-ee-19.4.2-ee.0.amazon2
# other series: 19.3.x -> 19.3.5, 19.2.x -> 19.2.8; Community Edition: gitlab-ce-<version>-ce.0.<suffix>
Arch Linux
sudo pacman -Syu
Alpine
apk update && apk upgrade gitlab-runner (runner only)
FreeBSD
pkg update && pkg upgrade gitlab-ce
Docker images
# in docker-compose.yml set: image: gitlab/gitlab-ee:19.4.2-ee.0  (other series: 19.3.x -> 19.3.5, 19.2.x -> 19.2.8; CE: gitlab/gitlab-ce:<version>-ce.0)
docker compose pull
docker compose up -d

General update steps for every system are on the Linux and Unix & BSD pages; after updating, see which services to restart.

Fix status in Linux distributions

ReleasePackageStatusFixed version / advisory
Debian 12ruby3.1not fixed yet
Debian 13ruby3.3not fixed yet
Debian testingruby3.3not fixed yet
Red Hat Enterprise Linux 9rubyaffected
Red Hat Enterprise Linux 9ruby:3.3/rubyaffected
Red Hat Enterprise Linux 9ruby:4.0/rubyaffected
Red Hat Enterprise Linux 8ruby:2.5/rubyaffected
Red Hat Enterprise Linux 8ruby:3.3/rubyaffected
Red Hat Enterprise Linux 7rubyaffected
Red Hat Enterprise Linux 6rubyaffected
Red Hat Enterprise Linux 10rubyaffected
Red Hat Enterprise Linux 10ruby4.0affected

From the Debian security tracker, Ubuntu CVE tracker and Red Hat Security Data API, refreshed every few hours.

Look for signs of exploitation

CISA required action: Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

Other products can potentially be affected by the same underlying Ruby/Onigmo Integer Overflow issue in CI/CD Regular Expression Compiler. For more information please see: https://www.ruby-lang.org/en/news/2026/10/23/regexp-fixes-for-gitlab-cves ; https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/ ; BOD 26-04: https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk ; Forensics Triage Requirements: https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk ; https://nvd

Related vulnerabilities

Sources

Page generated automatically from official sources on 2026-11-03 17:06 UTC and reviewed by an editor. Always confirm with your vendor's advisory.